Resolved | May 30, 2025 | 12:19 GMT+02:00
There are currently isolated problems with email delivery. We are working on a solution to the problem.
We have changed the main outgoing email address IP to 132.220.132.233 but this IP is new to many mail servers.
Update: While this IP and the main DNS of mail.signl4.com is not blacklisted anymore and outgoing email traffic has normalized, please make sure to explicitly whitelist the new IP with your mail server, if applicable.