Incident

Phone calls / call routing impaired

Resolved | Nov 11, 2025 | 09:05 GMT+01:00

The issue affecting phone calls to call routing numbers in the +4915888 range has been resolved by the telephony infrastructure provider.

Monitoring | Nov 10, 2025 | 17:57 GMT+01:00

We've been notified by our telephony infrastructure provider that calls to numbers beginning with +49158 are recovering. We'll continue to monitor the situation and provide another update as soon as it becomes available.

Investigating | Nov 10, 2025 | 12:13 GMT+01:00

There are currently disruptions with call forwarding. However, this currently affects only SIGNL4 call forwarding numbers that begin with +49158.
We are currently working together with the telephony infrastructure provider to resolve this issue.

Status Page powered by Admin Labs